Множественное выделение и копирование в табличной части

Функция для копирования при множественном выделении

В табличной части можно установить возможность выделения сразу нескольких строк, но, почему то, в случае множественного выделения не работает стандартный обработчик копирования. Пришлось писать процедуру самому, например:

Процедура МножественноеКопирование(ТабличнаяЧасть)
    ВыделенноеВТаблице = ЭлементыФормы.ТабличнаяЧасть.ВыделенныеСтроки;

    Если ВыделенноеВТаблице.Количество() > 0 Тогда
        Для Каждого Стр из ВыделенноеВТаблице Цикл
            нСтр = ТабличнаяЧасть.Добавить();
            нСтр.Колонка1 = Стр.Колонка1;
            нСтр.Колонка2 = Стр.Колонка2;
        КонецЦикла;
    КонецЕсли;
КонецПроцедуры

 

Оставить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *