Сортировка массива «Пузырьком»

Функция сортировки массива «МассивДляСортировки» по колонке «НомерСтроки»

Функция СортировкаМассива(МассивДляСортировки)
  // Количество просмотров массива
  Для Инд = 0 По МассивДляСортировки.Количество() - 1 Цикл
    // Просмотр массива
    Для ИндСтр = 0 ПО МассивДляСортировки.Количество() - 1 Цикл
      Если ИндСтр = МассивДляСортировки.Количество() - 1 Тогда
        Прервать;
      КонецЕсли;
  
      // Сравнение элементов и их перестановка (если требуется)
      Если МассивДляСортировки[ИндСтр].НомерСтроки > МассивДляСортировки[ИндСтр + 1].НомерСтроки Тогда
        СтаршийЭлемент = МассивДляСортировки[ИндСтр];
        МладшийЭлемент = МассивДляСортировки[ИндСтр + 1];
        МассивДляСортировки[ИндСтр] = МладшийЭлемент;
        МассивДляСортировки[ИндСтр + 1] = СтаршийЭлемент;
      КонецЕсли;
    КонецЦикла;
  КонецЦикла;
КонецФункции

 

Оставить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *