Копирование структуры в 1С

В этой небольшой статье рассмотрим как можно получить копию созданной структуры.

Предположим имеем следующую структуру:

Для копирования структуры в 1С 8 нельзя просто взять и написать такое: КопияСтруктуры = СозданнаяСтруктура. Вместо копии структуры мы просто получаем еще одну переменную КопияСтруктуры, которая указывает на тот же самый набор данных что и переменная СозданнаяСтруктура.
В этом случае поможет следующий цикл:

1 комментарий

  1. Функция КопияСтруктуры(СтруктураИсточник)
    СтруктураПриемник = Новый Структура;
    Для Каждого ЭлементСтруктуры Из СтруктураИсточник Цикл
    Если ТипЗнч(ЭлементСтруктуры.Значение) = Тип(«Структура») Тогда
    СтруктураПриемник.Вставить(ЭлементСтруктуры.Ключ, КопияСтруктуры(ЭлементСтруктуры.Значение));
    Иначе
    СтруктураПриемник.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
    КонецЕсли;
    КонецЦикла;
    Возврат СтруктураПриемник;
    КонецФункции

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *