Пустая дата в 1С

Очень часто необходимо проверить является ли поле с типом «Дата» или переменная, в которой хранится значение с этим типом, пустыми. Есть несколько способов выполнить эту проверку.

Проверка на пустую дату в текстах модулей

Если Дата = '00010101' Тогда
  //
КонецЕсли;

или

Если Дата = '00010101000000' Тогда
 //
КонецЕсли;

или

Если Дата = '0001-01-01' Тогда
  //
КонецЕсли;

или

Если Дата = Дата(1, 1, 1) Тогда
  //
КонецЕсли;

Проверка на пустую дату в запросах

ВЫБРАТЬ
	ЗаказПокупателя.Ссылка
ИЗ
	Документ.ЗаказПокупателя КАК ЗаказПокупателя
ГДЕ
	ЗаказПокупателя.Дата = ДАТАВРЕМЯ(1,1,1,0,0,0)

или

ВЫБРАТЬ
	ЗаказПокупателя.Ссылка
ИЗ
	Документ.ЗаказПокупателя КАК ЗаказПокупателя
ГДЕ
	ЗаказПокупателя.Дата = &ПустаяДата;

Запрос.УстановитьПараметр("ПустаяДата",'00010101');

2 комментария

    1. Хороший вопрос 🙂 Скорее всего ответ банален — в момент написания статьи я об этой функции не знал. Я тогда только только начинал учиться 1С и этот сайт разрабатывал для себя, для заметок. Поправлю статью 🙂

Оставить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *